Back to overview
Downtime
mycatalogcloud.com Productive Cloud Server is down
Apr 19 at 07:28am CEST
Resolved
Apr 19 at 08:30am CEST
mycatalogcloud.com Productive Cloud Server recovered
Affected services
Created
Apr 19 at 07:28am CEST
mycatalogcloud.com Productive Cloud Server went down
Affected services